<!doctype html>
	<!--[if !IE]>
	<html class="no-js non-ie" lang="en-GB"> <![endif]-->
	<!--[if IE 7 ]>
	<html class="no-js ie7" lang="en-GB"> <![endif]-->
	<!--[if IE 8 ]>
	<html class="no-js ie8" lang="en-GB"> <![endif]-->
	<!--[if IE 9 ]>
	<html class="no-js ie9" lang="en-GB"> <![endif]-->
	<!--[if gt IE 9]><!-->
<html class="no-js" lang="en-GB"> <!--<![endif]-->
<head><meta charset="UTF-8"/><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>


<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="robots" content="max-image-preview:large">
<meta name="geo.region" content="GB-LDN" />
<meta name="geo.placename" content="London" />

<!-- Global site tag (gtag.js) - Google Analytics -->
<script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=G-DBBNGYEPHW"></script>
<script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-DBBNGYEPHW');
</script>



<meta name='robots' content='max-image-preview:large' />

<link rel="alternate" type="application/rss+xml" title="ianVisits &raquo; Feed" href="https://www.ianvisits.co.uk/articles/feed/" />
<link rel="alternate" type="application/rss+xml" title="ianVisits &raquo; Comments Feed" href="https://www.ianvisits.co.uk/articles/comments/feed/" />







<link rel="https://api.w.org/" href="https://www.ianvisits.co.uk/articles/wp-json/" /><link rel="alternate" type="application/json" href="https://www.ianvisits.co.uk/articles/wp-json/wp/v2/posts/56105" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ianvisits.co.uk/articles/wp-includes/wlwmanifest.xml" /> 

<link rel="canonical" href="https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/" />
<link rel="alternate" type="application/json+oembed" href="https://www.ianvisits.co.uk/articles/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ianvisits.co.uk%2Farticles%2Flondons-newest-station-barking-riverside-opened-this-morning-56105%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ianvisits.co.uk/articles/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ianvisits.co.uk%2Farticles%2Flondons-newest-station-barking-riverside-opened-this-morning-56105%2F&#038;format=xml" />
<!-- We need this for debugging -->
<!-- Responsive 9.16.2 -->
<!-- responsive child 1.0.0 -->

<style id="aoatfcss" media="all">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</style><link rel="stylesheet" media="print" href="https://www.ianvisits.co.uk/articles/wp-content/cache/autoptimize/css/autoptimize_48851574d625950f4e544a6306467b08.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://www.ianvisits.co.uk/articles/wp-content/cache/autoptimize/css/autoptimize_48851574d625950f4e544a6306467b08.css" rel="stylesheet" /></noscript><title>London&#8217;s newest station &#8211; Barking Riverside opened this morning</title>

<!-- Facebook Opengraph -->


<meta name="description" content="Early this morning, the London Overground extension to Barking Riverside station opened, linking a future large housing estate to the rest of London.">

<meta property="fb:app_id" content="1777508015813682" />
<meta property="og:url" content="https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/" />
<meta property="og:type" content="website" />
<meta property="og:title" content="London&#8217;s newest station &#8211; Barking Riverside opened this morning" />
<meta property="og:description" content="Early this morning, the London Overground extension to Barking Riverside station opened, linking a future large housing estate to the rest of London."/>
<meta property="og:image" content="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17.jpg" />
<meta property="og:image:alt" content="London&#8217;s newest station &#8211; Barking Riverside opened this morning" />
<meta property="og:image:width" content="1800" />

<!-- Twitter Card -->
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:image" content="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17.jpg" />
<meta name="twitter:image:alt" content="London&#8217;s newest station &#8211; Barking Riverside opened this morning" />
<meta name="twitter:description" content="Early this morning, the London Overground extension to Barking Riverside station opened, linking a future large housing estate to the rest of London." />




<script type="rocketlazyloadscript" src='https://widgets.snack-projects.co.uk/gdpr/snack-cmp_v2.min.js' id='snack-cmp' async></script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script type="rocketlazyloadscript" async src="https://www.googletagmanager.com/gtag/js?id=UA-56476-3"></script>
<script type="rocketlazyloadscript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  
  gtag('event', 'detected', {
    'event_category': 'NTG adblock',
    'event_label': 'https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/',
    'non_interaction' : true
});

  gtag('config', 'UA-56476-3');
</script>

</head>

<body class="post-template-default single single-post postid-56105 single-format-standard default-layout">

<div id="container" class="hfeed">

<div class="skip-container cf">
	
<a class="skip-link screen-reader-text focusable" href="#content">&darr; Skip to Main Content</a>

</div><!-- .skip-container -->
<div id="header_section">
<div id="header-newer" role="banner">


<div class="websitelogo"><a href="https://www.ianvisits.co.uk">
<picture>
<source srcset="https://www.ianvisits.co.uk/images/logo-300-grey.webp" type="image/webp">
<source srcset="https://www.ianvisits.co.uk/images/logo-300-grey.png" type="image/png">
<img alt="IanVisits Logo" src="https://www.ianvisits.co.uk/images/logo-300-grey.png" style="background-image:  url('data:image/png;base64,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'); background-size: cover;">
</picture>
</a></div>


<div class="main-nav">
<div id="nav">  
<ul id="menu">
<li><a href="/calendar/">What's on in London</a>
<ul class="sub-menu">
<li><a href="/calendar/">London Today</a></li>
<li><a href="/calendar/tomorrow/">London Tomorrow</a></li>
<li><a href="https://www.ianvisits.co.uk/calendar/weekend.php">London this Weekend</a></li>
<li><a href="/calendar/free-london-exhibitions.php">Free exhibitons</a></li>
<li><a href="https://www.ianvisits.co.uk/theatre/london/">London Theatre</a></li>
<li><a href="/calendar/2022/07/">What's on in July 2022</a></li>
<li><a href="/calendar/2022/08/">What's on in August 2022</a></li>
<li><a href="/calendar/2022/09/">What's on in September 2022</a></li>
<li><a href="/calendar/2022/10/">What's on in October 2022</a></li>
<li><a href="/calendar/public-submit-event.php"><b>Add an Event</b></a></li>
</ul>
</li>
<li><a href="/articles/">London News</a>
<ul class="sub-menu">
<li><a href="https://www.ianvisits.co.uk/articles/category/architecture/">Architecture</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/art/">Art</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/books/">Book reviews</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/churches/">Churches</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/day-trips-from-london/">Day trips from London</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/food-and-drink/">Food and drink</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/history/">History</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/exhibition-review/">Exhibitions</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/london-theatre/">London Theatre</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/alleys/">Alleys and passages</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/londons-pocket-parks/">Pocket parks</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/museums/">Museums</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/category/transport-issues/">London Transport News</a></li>
</ul>
</li>
<li><a href="/anniversaries/">Anniversaries</a></li>
<li><a href="/london-museums/">London Museums</a></li>
<li><a href="/about/">Contact Me</a></li>
</ul>

<div id="hamburger">
      <div class="line" id="one"></div>
      <div class="line" id="two"></div>
      <div class="line" id="three"></div>
    </div>
</div>
</div>

  <div class="mobile-menu">
    <ul class="mobile-menu__items">
<li><a href="/calendar/">What's on in London</a></li>
<li><a href="/articles/">London News</a></li>
<li><a href="/anniversaries/">Anniversaries</a></li>
<li><a href="/london-museums/">London Museums</a></li>
<li><a href="/calendar/free-london-exhibitions.php">Free exhibitons</a></li>
<li><a href="/about/">Contact Me</a></li>



    </ul>
  </div>


<div class="clearfix"></div>


</div><!-- end of #header --></div>


	<div id="wrapper" class="clearfix">



<script type="application/ld+json">
{
   "@context": "https://schema.org",
   "@type": "NewsArticle",
   "url": "https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/",   
   "author": {
            "@type": "Person",
			"name": "Ian Mansfield",
            "givenName": "Ian",
            "familyName": "Mansfield",
            "additionalName": "ianVisits",
			"url": "https://www.ianvisits.co.uk/articles/about-ian-mansfield/"
   },   
   "publisher":{
      "@type":"Organization",
      "name":"ianVisits",
      "logo":{"@type":"ImageObject","url":"https://www.ianvisits.co.uk/images/big-logo.png","width":"1200","height":"675" }
   },
   "headline": "London&#8217;s newest station &#8211; Barking Riverside opened this morning",
   "mainEntityOfPage": "https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/",
   "image":["https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17.jpg"],
   "datePublished":"18 July 2022"
   
   
   
}
</script>










<div class="h1wrapper">
<h1 class="entry-title post-title responsive">London&#8217;s newest station &#8211; Barking Riverside opened this morning</h1>
</div>

<div id="content" class="grid col-620" role="main">

		
	

		
						<div id="post-56105" class="post-56105 post type-post status-publish format-standard has-post-thumbnail hentry category-transport-issues tag-barking-riverside tag-london-overground" style="padding:0.5em;">
								
				
	<!-- <h1 class="entry-title post-title responsive">xLondon&#8217;s newest station &#8211; Barking Riverside opened this morning</h1> //-->

<div class="post-meta">
	<span class="meta-prep meta-prep-author posted">Published </span><time class="timestamp updated" datetime="2022-07-18T12:00:32+01:00">18 July 2022</time><span class="byline"> by </span><span></span>		<!-- <span class="timestamp">By <a href="https://www.ianvisits.co.uk/articles/about-ian-mansfield/" style="color:#7e7e7e">Ian Mansfield</a></span> //-->
		<span class='posted-in'>
		<a href="https://www.ianvisits.co.uk/articles/category/transport-issues/">Transport News</a>		</span>
		
			<span class="comments-link">
		<span class="mdash">&mdash;</span>
			<a href="https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/#respond">No Comments &darr;</a>		</span>
	</div><!-- end of .post-meta -->

				<div class="post-entry">
<!-- Article Start -->
					<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p>Early this morning, the <a href="https://www.ianvisits.co.uk/articles/tag/london-overground/">London Overground</a> extension to <a href="https://www.ianvisits.co.uk/articles/tag/barking-riverside/">Barking Riverside</a> station opened, linking a future large housing estate to the rest of London.</p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img class="aligncenter size-medium wp-image-56121" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" loading="none" data-eio="p"></picture></a></p>
<p>Depending on how you look at it, the station is either late as it was due to open last year, or early, as the revised opening date had been this autumn.</p>
<p>The &pound;327 million link with its long curving viaduct, new station and provision for a second station will open up the huge Riverside housing development where eventually some 10,000 homes will be built, and later, if permission is granted, another 11,000 homes to the north where provision exists for a second station to be added at <a href="https://www.ianvisits.co.uk/articles/barking-wants-to-bury-a-road-and-build-a-railway-station-39069/">Castle Green</a>.</p>
<p>This morning though was the opening day for the new station at Barking Riverside, so long as people got up very early to avoid the heat and be on the first train. The first passenger train to arrive at Barking Riverside arrived at 6:50am &ndash; a minute late because of a delay caused by a late running freight train ahead of it at Barking station. There&rsquo;s a bit of give in the timetable to allow for that, and what was a 3-minute delay at Barking was almost entirely recovered by the time the train arrived at Barking Riverside, and eliminated by the time the train left.</p>
<p>It&rsquo;s a short ride along the existing railway from Barking station before the old ballast is replaced with brand new concrete and the railway rises up on a long curving viaduct that offers good views across the landscape that will soon be full of housing.</p>
<p>It&rsquo;s only a few minutes until the train pulls into the wide platforms at Barking Riverside station.</p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56119" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-15.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p>Possibly the most surprising thing about the station is the view it offers of the surrounding area, as it has a very good vantage of the Thames. This is the industrial Thames, but personally, I find it just as appealing to see as the central London river. Be aware that over time, the view will disappear though as the station will eventually be surrounded by the housing that will provide it with passengers, so pay a visit this year to admire the view. If coming for the view from the platforms, I&rsquo;d suggest an evening visit, as the sun will be behind you when looking out across the river.</p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56118" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-14.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p>As the station is quite high up compared to the current landscape, there are a number of glass walls on the platform to provide windbreaks</p>
<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<div class="mobileonly" style="margin:0.5em auto;">
<div id="snack_mpu"></div>
</div></div>

<p>Thanks to the timetable alignment, one train arrives at the station about a minute before the other leaves &mdash; so this two-platform station is already making full use of both platforms. The station is also designed for future 5-car trains when they are required. Something else the station has two of is lifts. As this is a new station, there&rsquo;s space to design two lifts into the building, reducing the risk of people arriving and finding there&rsquo;s no step-free access because a lift is being repaired. There&rsquo;s also a disability compliant toilet on the pay-side of the ground floor.</p>
<p>There&rsquo;s space on the ground floor for the obligatory retail outlet, and also a cashpoint machine. There&rsquo;s also a substantial secure cycle storage space inside that mirrors the space on the other side of the station for the shop.</p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56107" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-03.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p>The station is also double-sided for entrances, with the eastern side currently a long winding walk through a building site for future homes, but the western side is laid out with a new road and cycle lanes with spaces for drop-off taxi/disabled parking and bus stops.</p>
<div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<div class="mobileonly" style="width:300px; margin:0.5em auto;">
<div id="snack_dex2"></div>
</div></div>

<p>From the outside, the station is a large long rectangular slab that&rsquo;s visually split into three horizontal slices and that slicing of the architecture helps to create a visual effect of a long low-level station, when in fact it&rsquo;s quite tall.</p>
<p>The grey steel and glass upper deck sits above a long line of corten steel panels that have a mixed appearance depending on how close you are to terracotta roof tiles from a distance to the perforated steel sheets up close.</p>
<p>At the moment, the landscape around the station is a building site, which gives the area an oddly nostalgic air as it&rsquo;s a reminder of how the DLR often felt when it was being first being built. It&rsquo;s how transport should be done though, built the infrastructure first and then the housing will follow, along with the schools and shops and GP surgeries. That&rsquo;s what&rsquo;s happening at Barking Riverside, as a new railway enables the construction, over time, of over 20,000 new homes.</p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56123" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-01.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p>Although most of the land around the station is a building site waiting for housing, to the north of the riverside, housing was built years ago in expectation of transport links that never arrived, they&rsquo;ve had a couple of decades of broken promises that have now at long last been delivered.</p>
<p>Barking Riverside is finally on the map.</p>
<div id="attachment_55395" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img aria-describedby="caption-attachment-55395" loading="lazy" class="size-medium wp-image-55395" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/tfl-map-barking-riverside-station.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a><p id="caption-attachment-55395" class="wp-caption-text">Extract from tube map (c) TfL</p></div>
<p>The station opened to passengers this morning, but because of the heatwave, the official opening that was to happen later today has been delayed to a day when the weather won&rsquo;t melt the ceremonial ribbon before it can be cut. So, just like the Queen, Barking Riverside station will have two birthdays.</p>
<h2>Some more photos</h2>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56106" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-02.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56108" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-04.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56109" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-05.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56110" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-06.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56111" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-07.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56112" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-08.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56113" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-09.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56114" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-10.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56115" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-11.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<div class="mobileonly" style="width:300px; margin:0.5em auto;">
<div id="snack_dex3"></div>
</div></div>

<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56116" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-12.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56117" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-13.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56120" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-16.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<p><a href="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18.jpg" class="lightbox" ><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-900x500.jpg.webp 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18.jpg.webp 1800w" sizes='(max-width: 600px) 100vw, 600px' type='image/webp'><img loading="lazy" class="aligncenter size-medium wp-image-56122" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-600x333.jpg" alt="" width="600" height="333" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18-900x500.jpg 900w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-18.jpg 1800w" sizes="(max-width: 600px) 100vw, 600px" data-eio="p"></picture></a></p>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"72cb58a70a3659e0","token":"c1bf5fe0019845cba2101f8874a5b468","version":"2022.6.0","si":100}' crossorigin="anonymous"></script>
</body></html>
<div class="crp_related     crp-rounded-thumbs"><h3>Related Posts:</h3><ul><li><a href="https://www.ianvisits.co.uk/articles/the-northern-line-extension-opened-today-47410/"     class="crp_link post-47410"><figure><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12.jpg.webp 1800w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-600x333.jpg.webp 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-1024x569.jpg.webp 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-768x427.jpg.webp 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-1536x853.jpg.webp 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-100x56.jpg.webp 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-150x83.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-200x111.jpg.webp 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-300x167.jpg.webp 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-450x250.jpg.webp 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-900x500.jpg.webp 900w" sizes='(max-width: 150px) 100vw, 150px' type='image/webp'><img loading="lazy"  width="150" height="83"  src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12.jpg" class="crp_thumb crp_featured" alt="The Northern line extension opened today" title="The Northern line extension opened today" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12.jpg 1800w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-900x500.jpg 900w" sizes="(max-width: 150px) 100vw, 150px" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12.jpg 1800w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-600x333.jpg 600w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-1024x569.jpg 1024w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-768x427.jpg 768w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-1536x853.jpg 1536w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-100x56.jpg 100w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-150x83.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-200x111.jpg 200w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-300x167.jpg 300w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-450x250.jpg 450w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2021/09/northern-line-extension-12-900x500.jpg 900w" data-eio="p" /></picture></figure><span class="crp_title">The Northern line extension opened today</span></a></li><li><a href="https://www.ianvisits.co.uk/articles/london-overgrounds-barking-riverside-extension-will-open-next-monday-55930/"     class="crp_link post-55930"><figure><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-90x90.jpg.webp 90w" sizes='(max-width: 150px) 100vw, 150px' type='image/webp'><img loading="lazy"  width="150" height="150"  src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg" class="crp_thumb crp_featured" alt="London Overground&#039;s Barking Riverside extension will open next Monday" title="London Overground&#039;s Barking Riverside extension will open next Monday" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-90x90.jpg 90w" sizes="(max-width: 150px) 100vw, 150px" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-90x90.jpg 90w" data-eio="p" /></picture></figure><span class="crp_title">London Overground's Barking Riverside extension will open&hellip;</span></a></li><li><a href="https://www.ianvisits.co.uk/articles/london-overgrounds-barking-riverside-station-to-open-this-summer-55391/"     class="crp_link post-55391"><figure><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg.webp 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-90x90.jpg.webp 90w" sizes='(max-width: 150px) 100vw, 150px' type='image/webp'><img loading="lazy"  width="150" height="150"  src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg" class="crp_thumb crp_featured" alt="London Overground&#039;s Barking Riverside station to open this summer" title="London Overground&#039;s Barking Riverside station to open this summer" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-90x90.jpg 90w" sizes="(max-width: 150px) 100vw, 150px" srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-150x150.jpg 150w, https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/06/TfL-Image-BRE-station-nearing-completion-90x90.jpg 90w" data-eio="p" /></picture></figure><span class="crp_title">London Overground's Barking Riverside station to open this&hellip;</span></a></li></ul><div class="crp_clear"></div></div>
										
<!-- Article End -->

								
					



					

									</div><!-- end of .post-entry -->
				
				
	
				
<div class="clearfix"></div>

<div class="smallscreenonly">


</div>
<div class="clearfix"></div>
				

<div class="mobileonly sendysubscribe" style="width:100%; margin-top:1em; border-radius:0px;">
<div class="sendyheader" style="border-radius:0px;">NEWSLETTER</div>
<form action="https://www.ianvisits.co.uk/about/newsletter-subscription.php" method="POST" accept-charset="utf-8" style="padding: 0.5em; margin:0px;" id="subscribe-form"><p>Be the first to know what's on in London, and the latest news published on ianVisits.</p><p><label for="namemob">Your name</label><input type="text" name="name" id="namemob"/></p><p><label for="email1mob">Your email</label><input type="email" name="email" id="email1mob"/></p><div style="display:table"><div style="display:table-row"><div style="display:table-cell"><p><label for="Mondaynewsroundupmob">Monday news roundup</p></label></div><div style="display:table-cell"><input type="checkbox" name="Mondaynewsroundup" id="Mondaynewsroundupmob" value="yes" checked /></div></div><div style="display:table-row"><div style="display:table-cell"><p><label for="Wednesdayeventsguidemob">Wednesday events guide</p></label></div><div style="display:table-cell"><input type="checkbox" name="Wednesdayeventsguide" id="Wednesdayeventsguidemob" value="yes" checked /></div></div></div><div style="display:none;"><label for="hpmob">HP</label><input type="text" name="hp" id="hpmob"/></div><input type="hidden" name="list" value="GDp8DakhOo5qeX21FvmGKg"/><input type="hidden" name="subform" value="yes"/><p class="submitp"><input type="submit" value="Subscribe"></p><p>You can unsubscribe at any time from my weekly emails.</p></form>

</div>

<div class="clearfix"></div>

<div class="smallscreenonly">



</div>
<div class="clearfix"></div>
				

				
				

				<div class="navigation">
					<div class="previous">&#8249; <a href="https://www.ianvisits.co.uk/articles/londons-alleys-old-fish-street-hill-ec4-56087/" rel="prev">London&#8217;s Alleys: Old Fish Street Hill, EC4</a></div>
					<div class="next"></div>
				</div><!-- end of .navigation -->

				
		<div class="post-data">
		Tagged with: <a href="https://www.ianvisits.co.uk/articles/tag/barking-riverside/" rel="tag">barking riverside</a>, <a href="https://www.ianvisits.co.uk/articles/tag/london-overground/" rel="tag">london overground</a><br />	</div><!-- end of .post-data -->

<div class="post-edit"></div>
						
				
				
<div class="spu-box donateappeal" style="box-shadow: rgba(255,69,0,.5) 0 0 14px; border: 1px solid #ff4500;">
<div style="background-color: #333; padding: 1em; color: #fff; border-radius: 16px 16px 0 0;">SUPPORT THIS WEBSITE</div>

<div style="padding: 0 1em;" class="donateappealpadding">

<p>This website has been running now for over a decade, and while advertising revenue contributes to funding the website, it doesn't cover the costs. That is why I have set up a facility with <a href="https://donorbox.org/support-ianvisits-reporting-and-events-guide">DonorBox</a> where you can contribute to the costs of the website and time invested in writing and research for the news articles.</p>

<p>It's very similar to the way The Guardian and many smaller websites are now seeking to generate an income in the face of rising costs and declining advertising.</p>

<p>Whether it's a one-off donation or a regular giver, every additional support goes a long way to covering the running costs of this website, and keeping you regularly topped up doses of Londony news and facts.</p>

<p>If you like what you read on here, then please support the website <a href="https://donorbox.org/support-ianvisits-reporting-and-events-guide"><strong>here</strong></a>.</p>

<p style="text-align:right">Thank you</p>

</div>

</div>




			</div>
			
						




		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.ianvisits.co.uk/articles/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" size="30" autocomplete="off" /></p>
<p class="comment-form-email"><label for="email">Email</label> <span class="required">*</span><input id="email" name="email" type="text" value="" size="30" autocomplete="off" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='56105' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2f10d590a9" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="158"/><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	

			
		





<div itemscope itemtype="https://schema.org/BreadcrumbList">

<span itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a itemprop="item" href="https://www.ianvisits.co.uk"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span> >>

<span itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a itemprop="item" href="https://www.ianvisits.co.uk/articles/"><span itemprop="name">News</span></a><meta itemprop="position" content="2" /></span> >>

<span itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a itemprop="item" href="https://www.ianvisits.co.uk/articles/category/transport-issues/"><span itemprop="name">Transport News</span></a><meta itemprop="position" content="3" /></span>

</div>



</div><!-- end of #content -->








<div id="sidebar" class="grid col-300 fit" style="position: relative;">

<div class="sidebarcontent" style="margin-top: 0px;">
<h5 class="widgettitle" style="width: 100%;">Keep up with ianVisits</h5>
<div style="height:90px; display:table-cell; vertical-align:middle; width:100%"><picture>
  <source srcset="https://www.ianvisits.co.uk/images/social-buttons.webp" type="image/webp">
  <source srcset="https://www.ianvisits.co.uk/images/social-buttons.png" type="image/png"> 
  <img src="https://www.ianvisits.co.uk/images/social-buttons.png" alt="Social Media" usemap="#image-map" loading="lazy" width="300" height="60">
</picture>
</div>
<map name="image-map">
<area target="_blank" alt="Facebook" title="Facebook" href="https://www.facebook.com/ianvisits" coords="4,7,48,52" shape="rect" rel="noreferrer noopener nofollow">
<area target="_blank" alt="Twitter" title="Twitter" href="https://twitter.com/ianvisits" coords="65,7,110,52" shape="rect" rel="noreferrer noopener nofollow">
<area target="_blank" alt="LinkedIn" title="LinkedIn" href="https://www.linkedin.com/company/ianvisits/" coords="126,7,173,53" shape="rect" rel="noreferrer noopener nofollow">
<area target="_blank" alt="RSS" title="RSS" href="https://www.ianvisits.co.uk/articles/feed/" coords="189,6,234,52" shape="rect" rel="noreferrer noopener">
<area target="_blank" alt="YouTube" title="YouTube" href="https://www.youtube.com/channel/UC07K6eI9Lx-r-qyZMwKMDxg" coords="251,7,295,52" shape="rect" rel="noreferrer noopener nofollow">
</map>
</div>




<div class="upper-mpu sidebarcontent bigscreenonly">   
<div class="upper-mpu-inner" style="width:300px; margin:5px;">

<div id="snack_dmpu"></div>


	
</div>
</div>




<div class="sidebarcontent bigscreenonly" style="border: 0px;">




<div class="sendysubscribe" style="width:310px;">
<h5 class="widgettitle" style="width: 100%;">NEWSLETTER</h5>

<form action="https://www.ianvisits.co.uk/about/newsletter-subscription.php" method="POST" accept-charset="utf-8" style="padding: 0.5em; margin:0px;">
<p>Be the first to know what is on in London, and the latest news published on ianVisits.</p><p><label for="name">Your name</label><input type="text" name="name" id="name" /></p><p><label for="email1">Your email</label><input type="email" name="email" id="email1" /></p><div style="display:table"><div style="display:table-row"><div style="display:table-cell"><p><label for="Mondaynewsroundup">Weekly news roundup</p></label></div><div style="display:table-cell"><input type="checkbox" name="Mondaynewsroundup" id="Mondaynewsroundup" value="yes" checked /></div></div><div style="display:table-row"><div style="display:table-cell"><p><label for="Wednesdayeventsguide">Weekly events guide</p></label></div><div style="display:table-cell"><input type="checkbox" name="Wednesdayeventsguide" id="Wednesdayeventsguide" value="yes" checked /></div></div></div><div style="display:none;"><label for="hp">HP</label><input type="text" name="hp" id="hp" /></div><input type="hidden" name="list" value="GDp8DakhOo5qeX21FvmGKg" /><input type="hidden" name="subform" value="yes" /><p class="submitp"><input type="submit" value="Subscribe"></p><p>You can unsubscribe at any time from my weekly emails.</p>
</form>
</div>



</div>

<div class="sidebarcontent">
<h5 class="widgettitle">Latest five articles</h5>
<input type='checkbox' style='display: none' id="cb1"><label for="cb1" class="toggle"></label>


<ul class="puff" style="padding:0; margin:0px;">
<li><div style="display:table; width: 100%;"><div style="display:table-row"><div style="display:table-cell; vertical-align:top; padding-left: 0.5em;"><a href="https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/">London&#8217;s newest station &#8211; Barking Riverside opened this morning</a></div><div style="display:table-cell; width:100px; vertical-align:top;"><a href="https://www.ianvisits.co.uk/articles/londons-newest-station-barking-riverside-opened-this-morning-56105/"><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-90x90.jpg.webp"  type='image/webp'><img src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-90x90.jpg" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/barking-riverside-station-17-90x90.jpg" height="90" width="90" alt="London&#8217;s newest station &#8211; Barking Riverside opened this morning" loading="lazy" style="display:block; height: 90px; width: 90px;" data-eio="p"></picture></a></div></div></div></li><li><div style="display:table; width: 100%;"><div style="display:table-row"><div style="display:table-cell; vertical-align:top; padding-left: 0.5em;"><a href="https://www.ianvisits.co.uk/articles/londons-alleys-old-fish-street-hill-ec4-56087/">London&#8217;s Alleys: Old Fish Street Hill, EC4</a></div><div style="display:table-cell; width:100px; vertical-align:top;"><a href="https://www.ianvisits.co.uk/articles/londons-alleys-old-fish-street-hill-ec4-56087/"><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/old-fish-street-hill-02-90x90.jpg.webp"  type='image/webp'><img src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/old-fish-street-hill-02-90x90.jpg" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/old-fish-street-hill-02-90x90.jpg" height="90" width="90" alt="London&#8217;s Alleys: Old Fish Street Hill, EC4" loading="lazy" style="display:block; height: 90px; width: 90px;" data-eio="p"></picture></a></div></div></div></li><li><div style="display:table; width: 100%;"><div style="display:table-row"><div style="display:table-cell; vertical-align:top; padding-left: 0.5em;"><a href="https://www.ianvisits.co.uk/articles/rail-firms-asking-people-to-avoid-travelling-during-the-heatwave-56075/">Rail firms asking people to avoid travelling during the heatwave</a></div><div style="display:table-cell; width:100px; vertical-align:top;"><a href="https://www.ianvisits.co.uk/articles/rail-firms-asking-people-to-avoid-travelling-during-the-heatwave-56075/"><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/Buckled-rails-2018-90x90.jpg.webp"  type='image/webp'><img src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/Buckled-rails-2018-90x90.jpg" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/Buckled-rails-2018-90x90.jpg" height="90" width="90" alt="Rail firms asking people to avoid travelling during the heatwave" loading="lazy" style="display:block; height: 90px; width: 90px;" data-eio="p"></picture></a></div></div></div></li><li><div style="display:table; width: 100%;"><div style="display:table-row"><div style="display:table-cell; vertical-align:top; padding-left: 0.5em;"><a href="https://www.ianvisits.co.uk/articles/now-you-can-go-for-a-swim-in-canary-wharfs-docks-56038/">Now you can go for a swim in Canary Wharf&#8217;s docks</a></div><div style="display:table-cell; width:100px; vertical-align:top;"><a href="https://www.ianvisits.co.uk/articles/now-you-can-go-for-a-swim-in-canary-wharfs-docks-56038/"><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/canary-wharf-swimming-90x90.jpg.webp"  type='image/webp'><img src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/canary-wharf-swimming-90x90.jpg" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/canary-wharf-swimming-90x90.jpg" height="90" width="90" alt="Now you can go for a swim in Canary Wharf&#8217;s docks" loading="lazy" style="display:block; height: 90px; width: 90px;" data-eio="p"></picture></a></div></div></div></li><li><div style="display:table; width: 100%;"><div style="display:table-row"><div style="display:table-cell; vertical-align:top; padding-left: 0.5em;"><a href="https://www.ianvisits.co.uk/articles/half-price-sale-on-tickets-to-south-pacific-at-sadlers-wells-56030/">Half-price sale on tickets to South Pacific at Sadler&#8217;s Wells</a></div><div style="display:table-cell; width:100px; vertical-align:top;"><a href="https://www.ianvisits.co.uk/articles/half-price-sale-on-tickets-to-south-pacific-at-sadlers-wells-56030/"><picture><source srcset="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/Screenshot-2022-07-14-at-10-40-14-event-list-image_35364.webp-WEBP-Image-600-×-400-pixels-90x90.jpg.webp"  type='image/webp'><img src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/Screenshot-2022-07-14-at-10-40-14-event-list-image_35364.webp-WEBP-Image-600-×-400-pixels-90x90.jpg" src="https://www.ianvisits.co.uk/articles/wp-content/uploads/2022/07/Screenshot-2022-07-14-at-10-40-14-event-list-image_35364.webp-WEBP-Image-600-×-400-pixels-90x90.jpg" height="90" width="90" alt="Half-price sale on tickets to South Pacific at Sadler&#8217;s Wells" loading="lazy" style="display:block; height: 90px; width: 90px;" data-eio="p"></picture></a></div></div></div></li></ul></table></div> 

<div class="sidebarcontent bigscreenonly">
<div style="width:300px; margin:5px;">

<div id="snack_dex4"></div>

</div>
</div>


<div class="sidebarcontent">
<h5 class="widgettitle">What's on in London</h5>
<input type="checkbox" style="display: none" id="cb2"><label for="cb2" class="toggle"></label>
<ul style="margin: 0 0 0.5em 0.5em;">
<li><a href="https://www.ianvisits.co.uk/calendar/">Today</a></li>
<li><a href="https://www.ianvisits.co.uk/calendar/tomorrow/">Tomorrow</a></li>
<li><a href="https://www.ianvisits.co.uk/calendar/weekend.php">This Weekend</a></li>
<li><a href="/calendar/2022/07/">What's on in London in July 2022</a></li>
<li><a href="/calendar/2022/08/">What's on in London in August 2022</a></li>
<li><a href="/calendar/2022/09/">What's on in London in September 2022</a></li>
<li><a href="/calendar/2022/10/">What's on in London in October 2022</a></li>
</ul>

</div>


<div class="sidebarcontent bigscreenonly">
<div style="width:300px; margin:5px auto">

<div id="snack_dex5"></div>

</div>
</div>



<div class="sidebarcontent">
<h5 class="widgettitle">Article Categories</h5>
<input type="checkbox" style="display: none" id="cb3"><label for="cb3" class="toggle"></label>
<ul style="margin: 0 0 0.5em 0.5em; text-align:left;">
<li><a href="/articles/category/books/">Books</a></li>
<li><a href="/articles/category/history/">History</a></li>
<li><a href="/articles/category/churches/">Churches</a></li>
<li><a href="/articles/category/museums/">Museums</a></li>
<li><a href="/articles/category/architecture/">Architecture</a></li>
<li><a href="/articles/category/londons-pocket-parks/">Pocket Parks</a></li>
<li><a href="/articles/category/museum-meals/">Museum Meals</a></li>
<li><a href="/articles/category/unbuilt-london/">Unbuilt London</a></li>
<li><a href="/articles/category/transport-issues/">Transport News</a></li>
<li><a href="/articles/category/exhibition-review/">London Exhibitions</a></li>
<li><a href="/articles/category/ticket-alert/">London Ticket Alert</a></li>
<li><a href="/articles/category/alleys/">Alleys and Passages</a></li>
<li><a href="/articles/category/day-trips-from-london/">Day trips from London</a></li>
</ul>
</div>



<div class="sidebarcontent sidebarsmallscreenonly">
<h5 class="widgettitle">Top Tags</h5>
<input type="checkbox" style="display: none" id="cb5"><label for="cb5" class="toggle"></label>
<ul style="margin: 0 0 0.5em 0.5em; text-align:left;">
<li><a href="https://www.ianvisits.co.uk/articles/tag/london-transport-museum/" class="tag-cloud-link tag-link-225 tag-link-position-6" style="font-size: 1em;">London Transport Museum</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/illustrated-london-news/" class="tag-cloud-link tag-link-972 tag-link-position-7" style="font-size: 1em;">Illustrated London News</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/river-thames/" class="tag-cloud-link tag-link-27 tag-link-position-8" style="font-size: 1em;">River Thames</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/network-rail/" class="tag-cloud-link tag-link-197 tag-link-position-9" style="font-size: 1em;">Network Rail</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/museum-of-london/" class="tag-cloud-link tag-link-1213 tag-link-position-10" style="font-size: 1em;">Museum Of London</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/steam-train/" class="tag-cloud-link tag-link-408 tag-link-position-11" style="font-size: 1em;">Steam Train</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/hs2/" class="tag-cloud-link tag-link-1523 tag-link-position-12" style="font-size: 1em;">HS2 Railway</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/science-museum/" class="tag-cloud-link tag-link-1064 tag-link-position-13" style="font-size: 1em;">Science Museum</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/london-overground/" class="tag-cloud-link tag-link-1166 tag-link-position-14" style="font-size: 1em;">London Overground</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/canary-wharf/" class="tag-cloud-link tag-link-18 tag-link-position-15" style="font-size: 1em;">Canary Wharf</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/parliament/" class="tag-cloud-link tag-link-132 tag-link-position-16" style="font-size: 1em;">Parliament</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/docklands-light-railway-dlr/" class="tag-cloud-link tag-link-309 tag-link-position-17" style="font-size: 1em;">Docklands Light Railway (DLR)</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/ww2/" class="tag-cloud-link tag-link-24 tag-link-position-18" style="font-size: 1em;">Ww2</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/barbican/" class="tag-cloud-link tag-link-847 tag-link-position-19" style="font-size: 1em;">Barbican</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/greenwich/" class="tag-cloud-link tag-link-88 tag-link-position-20" style="font-size: 1em;">Greenwich</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/london-open-house-weekend/" class="tag-cloud-link tag-link-501 tag-link-position-21" style="font-size: 1em;">London Open House Weekend</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/southwark/" class="tag-cloud-link tag-link-46 tag-link-position-22" style="font-size: 1em;">Southwark</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/tower-bridge/" class="tag-cloud-link tag-link-79 tag-link-position-23" style="font-size: 1em;">Tower Bridge</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/victoria-and-albert-museum/" class="tag-cloud-link tag-link-359 tag-link-position-24" style="font-size: 1em;">Victoria And Albert Museum (V&amp;A)</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/docklands/" class="tag-cloud-link tag-link-222 tag-link-position-25" style="font-size: 1em;">Docklands</a></li><li><a href="https://www.ianvisits.co.uk/articles/tag/roman-london/" class="tag-cloud-link tag-link-39 tag-link-position-26" style="font-size: 1em;">Roman London</a></li>
</ul>
</div>



</div>

</div>

</div>



</div><!-- end of #wrapper -->
</div><!-- end of #container -->

<div id="footer" class="clearfix">
	
	<div id="footer-wrapper">

		

<div class="grid col-940">


<div class="sidebarcontent footerlinks">
<h5 class="widgettitle">Menu links</h5>
<input type="checkbox" style="display: none" id="cb6"><label for="cb6" class="toggle"></label>
<ul style="margin: 0 0 0.5em 0.5em; text-align:left;">
<li><a href="https://www.ianvisits.co.uk/calendar/" class="tag-cloud-link tag-link-225 tag-link-position-6">What's on in London</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/visitor-guide-to-london/" class="tag-cloud-link tag-link-225 tag-link-position-6">London visitor guide</a></li>
<li><a href="https://www.ianvisits.co.uk/theatre/london/" class="tag-cloud-link tag-link-225 tag-link-position-6">London theatre tickets</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/" class="tag-cloud-link tag-link-225 tag-link-position-6">London news</a></li>
<li><a href="https://www.ianvisits.co.uk/london-museums/" class="tag-cloud-link tag-link-225 tag-link-position-6">London museums</a></li>
<li><a href="https://www.ianvisits.co.uk/articles/privacy-policy/" class="tag-cloud-link tag-link-225 tag-link-position-6" style="font-size: 1em;">Privacy</a></li>
</ul>
<div class="clearfix"></div>
<p style="font-size:16px"><a href="https://www.ianvisits.co.uk">&copy; ianVisits</a></p>
</div>




</div>


		





<div class="grid col-300 copyright">
</div>

<div class="grid col-300 scroll-top">
</div>

<div class="grid col-300 fit powered"></div>






	</div><!-- end #footer-wrapper -->
	
</div><!-- end #footer -->

<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/articles(\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/ianm_login\/)|\/wp-admin\/|\/logout\/|\/ianm_login\/|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/www.ianvisits.co.uk\/articles","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.ianvisits.co.uk/articles/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js' defer></script>







<noscript><link media='all'  href="https://www.ianvisits.co.uk/images/lightbox/glightbox.min.css" rel="stylesheet" type="text/css" /></noscript><link media='print' onload="this.onload=null;this.media='all';"  href="https://www.ianvisits.co.uk/images/lightbox/glightbox.min.css" rel="stylesheet" type="text/css" />
<script type="rocketlazyloadscript" src="https://www.ianvisits.co.uk/images/lightbox/glightbox.min.js" data-rocket-type="text/javascript" defer></script>
<script type="rocketlazyloadscript">
document.addEventListener('DOMContentLoaded', function(event) {
const lightbox  = GLightbox({ selector: '.post-entry .lightbox', }); 
});
</script>

<script type="rocketlazyloadscript">
document.getElementById("hamburger").addEventListener("click", function(){
  this.classList.toggle("active");
  document.querySelector(".mobile-menu").classList.toggle("active");
});
</script>

<script type="rocketlazyloadscript" data-rocket-type="text/javascript" src="https://s.skimresources.com/js/152034X1617759.skimlinks.js" defer></script>

<div id="snack_dex1"></div>
<script type="rocketlazyloadscript">
    (function(){
        
        var site_id = 2821;
        var data_site_id = 0;

        var sn_cb = new Date().getMonth();
        var snack_hb = document.createElement('script');
        snack_hb.src = 'https://cdn-header-bidding.snack-media.com/assets/js/snack-loader/'+site_id+'?cb='+sn_cb;
        snack_hb.id = 'snack_ads';
        if(data_site_id){
            snack_hb.setAttribute('data-site-id',data_site_id);
        }
        document.body.appendChild(snack_hb);
        snack_hb.onerror = function(){
            document.body.removeChild(snack_hb);
            var snack_hb2 = document.createElement('script');
            snack_hb2.src = 'https://cdn2-header-bidding.snack-media.com/assets/js/snack-loader/'+site_id+'?cb='+sn_cb;
            snack_hb2.id = 'snack_ads';
            if(data_site_id){
                snack_hb2.setAttribute('data-site-id',data_site_id);
            }
            document.body.appendChild(snack_hb2);
        };
    })();
</script>

<script type="rocketlazyloadscript" src="/images/adblock/sailthru.js" data-rocket-type="text/javascript" defer></script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript"> if(!document.getElementById('JSvtndQoTVsH')){ document.getElementById('PsmjNtyHTqkY').style.display='block'; } </script>

</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->